Your PHP installation appears to be missing the MySQL extension which is required by WordPress

Ao visitar seu site WordPress, é possível que você veja este erro:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Isso é causado quando o código PHP no seu site não é compatível com a versão do PHP que o site está usando no momento. Mais especificamente, o problema está na extensão desatualizada do MySQL, que foi removida a partir do PHP 7.0.

Se você estiver usando qualquer versão do PHP acima da 7.0 e estiver vendo esse erro, é devido ao código antigo que precisa ser atualizado. Você precisará atualizar os arquivos principais do WordPress para a versão atual, bem como os plug-ins que o site estiver usando.

Verifique qual versão do PHP você está usando no site

Primeiro, verifique qual versão do PHP seu site está usando com um arquivo phpinfo.php.

Verifique se ele corresponde à versão do PHP que seu painel mostra para o seu domínio.

Atualizando seu código

Se seu site foi atualizado para uma versão do PHP acima de 7.0 e você está vendo esse erro, isso significa que você deve atualizar sua versão principal do WordPress e plug-ins para usar as extensões MySQLi ou PDO_MySQL mais recentes.

Atualizando o WordPress

Se você instalou o WordPress como Instalação com um clique, você pode atualizá-lo manualmente em seu painel ou definir a atualização automática.

E você pode atualizar seus plugins no seu painel.

Se você instalou o WordPress manualmente, é possível atualizá-lo no painel do WordPress.

Para servidores dedicados

Se você estiver em um servidor dedicado, sua versão do MySQL pode ser 5.6. Nesse caso, e você está vendo esse erro, adicione a seguinte linha ao arquivo phprc do seu site.

extension = mysql.so

Nós oferecemos todo o suporte especializado em WordPress para nossos clientes, se ainda não possuí uma hospedagem conosco, confira nossos planos: CLIQUE AQUI!